snrg.net
当前位置:首页 >> hADoop 2.8 可以用jDk1.8吗 >>

hADoop 2.8 可以用jDk1.8吗

没问题,jdk基本都是向下兼容的 我们在做dubbo接口开发是,要考虑jdk版本兼容的问题。如果是高版本的jre运行低版本jdk compile 的jar,根据java的向下兼容性,这个没有问题。但如果是低版本jre运行高版本的jdk compile的jar,会怎么样呢? 问题的...

看样子应该是 JAVA_HOME 环境变量没配置好,你看看 hadoop-env.sh 那里是否配置JAVA_HOME环境变量?

配置hosts文件,将主机名和对应IP地址... 1 配置SSH的无密码登录:可新建专用用户h... 2 hadoop配置过程:要实现分布式环境,配... 3 配置文件1:hadoop-env.sh该文件是hado

你没有安装或者配置JAVA_HOME,请查看你的/etc/profile、hadoop/conf/hadoop-env.sh等需要配置JDK的文件。 另外一种可能是你安装配置了JDK,但是没有source /etc/profile,或者source后没有退出当前shell并重新登录来刷新JDK配置。

重新配置jdk,配置完成后执行source /etc/profile,让配置文件立即生效,更多知识请查看《Linux就该这么学》,谢谢

你好。 根据你的描述: hadoop不同节点,是不能使用不同版本的JDK的,谨慎操作,希望能帮助到你!

可以的 1.所有命令,建议手敲,不建议复制粘贴,以避免因为页面空格造成的不必要错误。 2.务必保持网络畅通,如果出现缺少某个文件,则要先清理maven(使用命令 mvn clean) 再重新编译。 3.如果总是出现同一个错误导致编译失败,则可能是缺少某个...

bin/hadoop中接受的是namenode参数,不是Namenode,使用: bin/hadoop namenode -format 碰到这种情况,建议查看hadoop脚本或者代码。

Hadoop官方推荐使用SUN JDK,但OpenJDK一般环境下未发现问题,1.x使用JDK1.6,2.x使用JDK 1.7,目前不支持JDK1.8。这个回答仅限于x86架构下的Hadoop本身。不同的生态组件在不同的环境下可能会出现问题,去年我曾经给 Hortonworks的Hbase团队报告...

你好:我刚才上网查的资料,是可靠的,这个的话,Hadoop 2.6....Support JDK8

网站首页 | 网站地图
All rights reserved Powered by www.snrg.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com